emacs 下面使用ecb

额,这个东西主要用来看代码

一、安装

1、emacs

2、cedet 1.1

3、ecb-2.4

二、修改.emacs

1、前提是已经可以正常使用cedet了

2、在.emacs里增加

(add-to-list 'load-path
         "~/.emacs.d/ecb-2.40")
(require 'ecb)

3、重启emacs

然后m-x ecb-activate

结果ECB 2.40 - Error: ECB can only be used with cedet [1.0pre6, 1.0.9]! Please install it and restart Emacs!

解决办法:

更改ecb-2.4文件夹下的ecb-upgrade.el


(defconst ecb-required-cedet-version-max '(1 0 4 9))

将上面的1 0 4 9 改为1 1 4 9

然后重启emacs,就可以用ecb了。

添加新评论